Recent content by mrg.mrg. | TruckMount Forums #1 Carpet Cleaning Forums

Recent content by mrg.mrg.

  1. M

    Performer 405 help/advice badly needed

    I have two 405s and a legend with same heat exchanger but haven't had that issue yet. I'm sure if taken apart the leak can be welded...it's only metal after all. Where in TX are you? I can ask around and see if the shops here can help but might not be cheap.
  2. M

    New Stanley Steemer Scam

    I meant advertisement for the yellow van company
  3. M

    Threatening Phone Call

    This forum...come for the info....stay for the drama
  4. M

    New Stanley Steemer Scam

    So are we sure this isn't advertisement for that company? Sometimes I wonder....
  5. M

    Water temp issue, Preformer 405

    That's the same set up I got. I was about to tell you about the bypass too. Might be leaking water back to waste tank...You'd to run it, let it get hot, take cover off tank and see.
  6. M

    Quick Disconnect always seems to leak on the TM

    you can use a shut off valve before the quick connect, thats what I have just have to be sure the quick connect does not hit your door as it will stick out a couple of inches
  7. M

    bruin 2 one minute turns over next minute nothing. Only sound is fuel pump

    Good...on these older machines I've found that most of the time whoever had them before never cleaned anything and sold them because they didn't work... supposedly
  8. M

    Thermal wave ii vortec no pressure!

    Nice! Yeah those sensors always go bad. Mine are bypassed too and not really planning on ever getting them. Did you check conditions on high pressure hoses? Be ready to replace them as they get cooked and brittle and start leaking. Hydraulic shops should be able to do them for you. Just take old...
  9. M

    Thermal wave ii vortec no pressure!

    And yeah those relief valves you can find somewhere else for less. A lot of parts on these machines aren't as proprietary as the manufactures lead you to believe. And if for some reason they don't offer the part for your model you can almost always use from different model might just need to...
  10. M

    Thermal wave ii vortec no pressure!

    Or the ceramic plungers might be broken. you'll be able to see them once you take head of pump off. I had a similar issue and tried to feed the pump with a hose and it wouldn't pick up water so I did what i just described and pump is working fine.
  11. M

    Thermal wave ii vortec no pressure!

    Hmm I think that machine has nissan engine similar to 405 right? Maybe your pump is seized up. If that is the case just take the head off the pump and clean everything out. Sometimes the pumps are left with dirty water and the valves get stuck. Its just a matter of taking them out and cleaning...
  12. M

    bruin 2 one minute turns over next minute nothing. Only sound is fuel pump

    I dont know about the turns on the screw to the carb.
  13. M

    bruin 2 one minute turns over next minute nothing. Only sound is fuel pump

    start up sequence on bruin should be similar to my prochem so I assume you hold override switch as you start it....is it turning off when you let go of override? or does it stay on and then shuts off at random time?
  14. M

    bruin 2 one minute turns over next minute nothing. Only sound is fuel pump

    gpm of the pump I don't know but it should be low pressure pump...around 2 psi. I think you mean it goes to the bottom of filter...thats normal to see it pool up there...you can alway take fuel line off from carb...turn key and switch and pour fuel into a container and see if it keeps flowing...
  15. M

    bruin 2 one minute turns over next minute nothing. Only sound is fuel pump

    You might need to adjust carb and check fuel pump, lines and filter...something might be clogged...even if pump sounds like its working maybe its not working right.