4100lx Heater Issues | TruckMount Forums #1 Carpet Cleaning Forums

4100lx Heater Issues

Josh Hawkins

New Member
Aug 15, 2017
4
0
1
24
Real Name
Joshua Hawkins
I run a 4100lx steamway that has been having heater problems. I can't trouble shoot what is wrong with it. When I'm running the engine I turn the heat switch on and it will run and I can hear it burning but after about 5-8 seconds it cuts off. Then it will come on and off for a second until it completely stops. I have replaced the flow switch and checked all grounds. When the heater kicks off everything stops, it stops spraying kerosene and everything. Does anyone have a clue on how to fix this issue or can pint me in the right direction.
 

seagrtj

Well-Known Member
Jun 28, 2011
1,280
522
113
MO
Real Name
Todd Seagraves
Business Location
United States
Not real familiar with that heater, but do you know if it has a CAD cell or a flame sensor? If the there is one and is bad it would shut it off because it thinks there is no flame
 

Josh Hawkins

New Member
Aug 15, 2017
4
0
1
24
Real Name
Joshua Hawkins
Not real familiar with that heater, but do you know if it has a CAD cell or a flame sensor? If the there is one and is bad it would shut it off because it thinks there is no flame
I don't think it has either that I am aware of. When it runs for the few seconds I can hear the flame blowing which is why I am confused. When it runs I am getting a spark from the electrodes which is causing a flame and I'm getting kerosene flow from the pump.
 

JD5150

Well-Known Member
Oct 24, 2010
2,318
967
113
Real Name
JD S
Business Location
United States
I don't think it has either that I am aware of. When it runs for the few seconds I can hear the flame blowing which is why I am confused. When it runs I am getting a spark from the electrodes which is causing a flame and I'm getting kerosene flow from the pump.
Is the heater 12 volt battery powered or generator powered? I would call Steamway they should help you with the problem. 800-447-8326
 

Josh Hawkins

New Member
Aug 15, 2017
4
0
1
24
Real Name
Joshua Hawkins
Is the heater 12 volt battery powered or generator powered? I would call Steamway they should help you with the problem. 800-447-8326
It is run by a 12v battery. We thought the battery might be low on charge so I put a new one in and no change. I will give them a call though! Thank you
 

JD5150

Well-Known Member
Oct 24, 2010
2,318
967
113
Real Name
JD S
Business Location
United States
It is run by a 12v battery. We thought the battery might be low on charge so I put a new one in and no change. I will give them a call though! Thank you
You may have a connection problem on the ground or positive side of the battery. I put all new wires with brass terminals on mine. I have split the battery terminals before and it will give me a problem. Any small connection problem will give you a problem. I would check the wires from the battery back to the heater and make sure there is no bare/bad wires
 

Ara Klujian

Moderator & TMF Repair Expert
Moderator
Premium VIP
Jun 19, 2008
3,304
243
63
44
Chicago, IL
www.peterklujiancarpet.com
Real Name
ARA KLUJIAN
Business Location
United States
It is run by a 12v battery. We thought the battery might be low on charge so I put a new one in and no change. I will give them a call though! Thank you
The wiring inside DC Motor that turns the kerosene pump sounds like it it is shorted out. If you remove the kerosene pump with the two hex bolts the kerosene pump will pull right off the motor. (its pretty simple) Look inside the DC motor ! I suspect the flag terminal is loose or broken.
Another possibility is that the plastic coupler in the same location I just mentioned needs to be replaced.

If all that checks out ok then your Ignitor is most likely bad. If you need an ignitor I have one that I would love to sell! It's NEW!
 

Josh Hawkins

New Member
Aug 15, 2017
4
0
1
24
Real Name
Joshua Hawkins
Thanks everyone for the help! I've been scratching my head at this for a while now. I have been on and off the phone with our distributor all week working on it and we figured out that the fuse/breaker below the starter solenoid has gone bad! I can't believe I over looked that! It runs like a champ now! Thank y'all!
 

Ara Klujian

Moderator & TMF Repair Expert
Moderator
Premium VIP
Jun 19, 2008
3,304
243
63
44
Chicago, IL
www.peterklujiancarpet.com
Real Name
ARA KLUJIAN
Business Location
United States
Thanks everyone for the help! I've been scratching my head at this for a while now. I have been on and off the phone with our distributor all week working on it and we figured out that the fuse/breaker below the starter solenoid has gone bad! I can't believe I over looked that! It runs like a champ now! Thank y'all!
Great!
Keep me in mind if you need an ignitor. I really want to sell it!
 

RicksFamilyCarpet

New Member
Sep 28, 2015
3
0
1
40
Real Name
Steven Boyd
Late to the post, but I run a 2100 from steamway and I get stuck sometimes. I always call steamway - Kevin is really good at troubleshooting and keeping you from buying unnecessary parts. I have had to replace quite a few things over the last two years and he has been awesome. I don't have a distributor near me . so always have to order direct