Dwyer Meter Question | TruckMount Forums #1 Carpet Cleaning Forums

Dwyer Meter Question

Pakman

Member
Feb 5, 2018
41
8
8
Real Name
Justin Easterling
The ball in my Dwyer meter appears to be glued to the bottom of the glass. This seems strange because when priming or introducing air to the system I see bubbles and then see them disappear once primed. Even when bobbing the pick-up tube up and down the ball never budges.

I have verified flow through the prime tube and inspected all check valves except the outlet at the pump. I will do that soon. I also plan to check and see if I am using any chemical.

Can anyone think of anything else to look for? I'm not leaning towards a bad pump, but maybe I should be?
 
Last edited:

Pakman

Member
Feb 5, 2018
41
8
8
Real Name
Justin Easterling
Update: Seems to be working fine but I'm not sure I fixed anything... my luck is the problem returns as soon as I think I'm good to go.

With the selector switch in the "chemical" position I operated the pump and removed the pick-up hose. My intent was to see if air would be pulled into the system...it wasn't. I replaced the pick-up hose and attempted to prime... this is when the ball sprung to the top of the meter. I'm getting chemical and everything seems fine... for now.

Hopefully something was just stuck in that outlet check valve that I haven't inspected yet.
 

Swani21

Well-Known Member
Oct 8, 2015
878
403
63
Real Name
Nick S.
I often have to put mine to prime and then plug my vacuum port and keep priming till the ball stays at the top for 10 seconds.
 
  • Like
Reactions: Pakman

Rory henderson

Active Member
Sep 22, 2015
362
189
43
47
Real Name
Rory henderson
When that happen to me I changed out everything from the chemical pump to solution pump & it ended up being a slit in the chemical solution line that goes in the 5 gallon jug
 
  • Like
Reactions: Pakman

wandwizard

Randy Dockins
Premium VIP
Nov 12, 2008
8,644
3,385
113
Real Name
Randy Dockins
Business Location
United States
I think I may have had just about everything that can cause the Dwyer not to draw happen at one time or another. This year I had a new thing and it was the very last thing I thought could happen, but it did happen. My Dwyer was very old since it was original to my machine and it developed a hairline crack in it that I couldn't detect. I found out later that you can drain the line and inject compressed air in the line to find where the leak is. I wished I'd known that sooner cause it would've saved me some money. Before this I also had the 3-way selector valve go bad on me. When that happens air will leak into the system and you won't draw any chemical. When you set it to Prime it will still prime, but that's just because it's being pulled by vacuum, not the chemical pump. There are at least 2 or 3 other things that will cause it not to draw, but I don't think these 2 are even in the manual.

I hope you have it fixed. I've had quite a few problems with chemical pumps over the years. I think a lot of guys wind up just throwing them in the trash, but I do like to have chemical injection.
 
  • Like
Reactions: Pakman

Pakman

Member
Feb 5, 2018
41
8
8
Real Name
Justin Easterling
I think I may have had just about everything that can cause the Dwyer not to draw happen at one time or another. This year I had a new thing and it was the very last thing I thought could happen, but it did happen. My Dwyer was very old since it was original to my machine and it developed a hairline crack in it that I couldn't detect. I found out later that you can drain the line and inject compressed air in the line to find where the leak is. I wished I'd known that sooner cause it would've saved me some money. Before this I also had the 3-way selector valve go bad on me. When that happens air will leak into the system and you won't draw any chemical. When you set it to Prime it will still prime, but that's just because it's being pulled by vacuum, not the chemical pump. There are at least 2 or 3 other things that will cause it not to draw, but I don't think these 2 are even in the manual.

I hope you have it fixed. I've had quite a few problems with chemical pumps over the years. I think a lot of guys wind up just throwing them in the trash, but I do like to have chemical injection.
That's great info! I appreciate it!

As I suspected, the problem has returned. However, now it primes but I'm not getting chemical. I also noticed that when the selector switch is off I'm still getting water from the prime tube. It worked for a day, then the meter started reading flow when the valve was closed, and now I get no chemical at all. Guess I'll replace my diaphragm and selector switch for a start.
 

wandwizard

Randy Dockins
Premium VIP
Nov 12, 2008
8,644
3,385
113
Real Name
Randy Dockins
Business Location
United States
That's great info! I appreciate it!

As I suspected, the problem has returned. However, now it primes but I'm not getting chemical. I also noticed that when the selector switch is off I'm still getting water from the prime tube. It worked for a day, then the meter started reading flow when the valve was closed, and now I get no chemical at all. Guess I'll replace my diaphragm and selector switch for a start.
I think the most common reason it reads flow when the meter is off is a hole in the diaphragm. I would just replace the diaphragm and go ahead and put 2 new check valves in there while you have it off. Those check valves are easy to replace and you may as well take care of them now. Your 3 way could still be good and they're kind of a pain to replace. Chances are rebuilding the chemical pump will solve your problem. I doubt you have a problem with the selector valve unless your machine is pretty old. Mine lasted almost 17 years before it gave me trouble.
 

Pakman

Member
Feb 5, 2018
41
8
8
Real Name
Justin Easterling
I think the most common reason it reads flow when the meter is off is a hole in the diaphragm. I would just replace the diaphragm and go ahead and put 2 new check valves in there while you have it off. Those check valves are easy to replace and you may as well take care of them now. Your 3 way could still be good and they're kind of a pain to replace. Chances are rebuilding the chemical pump will solve your problem. I doubt you have a problem with the selector valve unless your machine is pretty old. Mine lasted almost 17 years before it gave me trouble.
It's old lol. It's a Bridgepoint Systems unit that has about 5,000 hours. I baby it though!
 

wandwizard

Randy Dockins
Premium VIP
Nov 12, 2008
8,644
3,385
113
Real Name
Randy Dockins
Business Location
United States
It's old lol. It's a Bridgepoint Systems unit that has about 5,000 hours. I baby it though!
If it's that old I'd say it could be any of those things, but I'd still start with rebuilding the Chemical pump if you haven't done that in a while. I've basically gone through my entire chemical injection system including a brand new chemical pump, new 3 way valve, new Dwyer, new chem lines, and a new chemical check valve in just the last couple years. That Dwyer crack was the most problematic for me to figure out because I didn't know how to use an air compressor to check it for leaks. I got that info from Jondon's service dept. My machine had about 8,000 plus hours on it by the time I had all these problems. Until then I only had problems caused by the chemical pump itself.

Btw, if you change out your diaphragm and you are still getting continuous draw showing on your Dwyer it is almost certainly a bad chemical check valve. I am assuming your machine has one, but not 100% certain. It's a fairly expensive part so I wouldn't worry about it unless all else fails. Your manual should list one somewhere if it has it. Mine is right before the chemical exits the machine. I didn't even know that part was on the machine until I had the problem with it. It is separate from all the other injection parts.
 

Pakman

Member
Feb 5, 2018
41
8
8
Real Name
Justin Easterling
If it's that old I'd say it could be any of those things, but I'd still start with rebuilding the Chemical pump if you haven't done that in a while. I've basically gone through my entire chemical injection system including a brand new chemical pump, new 3 way valve, new Dwyer, new chem lines, and a new chemical check valve in just the last couple years. That Dwyer crack was the most problematic for me to figure out because I didn't know how to use an air compressor to check it for leaks. I got that info from Jondon's service dept. My machine had about 8,000 plus hours on it by the time I had all these problems. Until then I only had problems caused by the chemical pump itself.

Btw, if you change out your diaphragm and you are still getting continuous draw showing on your Dwyer it is almost certainly a bad chemical check valve. I am assuming your machine has one, but not 100% certain. It's a fairly expensive part so I wouldn't worry about it unless all else fails. Your manual should list one somewhere if it has it. Mine is right before the chemical exits the machine. I didn't even know that part was on the machine until I had the problem with it. It is separate from all the other injection parts.
Just picked up a diaphragm. Hopefully that fixes it. All the check valve seem ok. I think the one you are specifically talking about is on the manifold near the screen. I will definitely check my manual to make sure I'm not missing one.
 
  • Like
Reactions: wandwizard